В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
YourKarma396
YourKarma396
13.08.2020 09:20 •  Информатика

Составьте программу поиска максимального среди нечетных элементов массива. в массиве 30 целых чисел из интервала от 20 до 72.

Ответ:
cimuzoro
cimuzoro
24.06.2020 15:50
Например так:
program test;
uses crt;
var
  arr:array[1..30] of integer;
  i,max:integer;
begin
  randomize;
  for i:=1 to 30 do
    begin
      arr[i]:=random(53)+20;
      if (max=0) and (arr[i] mod 2 <> 0) then max:=arr[i];
      write(arr[i],' ');
    end;

  for i:=1 to 30 do
    if (arr[i] mod 2 <>0) and (arr[i]>max) the max:=arr[i];
  writeln;
  writeln(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?