В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dani00480
Dani00480
04.06.2022 00:38 •  Информатика

Нужно написать программу которая вычисляет полную площадь поверхности цилиндра. значения высоты и радиуса водятся с клавиатуры Язык C

можно исправить ошибки в моём коде

#include

#include

main()

{

int h =0;

int r=0;

int p=3.14;

int P=0;

printf("Введите первое целое число\n");

scanf("%d", &h);

printf("Введите второе целое число\n");

scanf("%d", &r);

P=2*p*r*(h+r);

printf ("%d",P);

getch();

}

Ответ:
konoval1i
konoval1i
11.10.2021 18:29

Переменные P и p должны быть вещественного типа, так как они представляют собой дробные числа. Какая ошибка выводится? CE или RE?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?