В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Yuska11
Yuska11
10.12.2021 08:08 •  Информатика

Напишите программу, которая будет генерировать список случайных чисел в диапазоне от 1 до 100. Длина списка тоже должна быть случайной в диапазоне от
10 до 20. Потом программа должна найти в этом списке все элементы, меньшие
заданного пользователем значения, сформировать из них новый список и
напечатать первоначальный и полученный списки.Напишите программу на питоне

Ответ:
aazzziizz
aazzziizz
26.08.2021 15:22

import random

list = []

numbers_range = random.randint(10, 20)

for i in range(numbers_range):

   numbers = random.randint(1, 100)

   i = numbers

   list.append(i)

user_number = int(input('Введите число: '))

user_list = []

for j in list:

   if j < user_number:

       user_list.append(j)

print(list)

print(user_list)

Объяснение:


Напишите программу, которая будет генерировать список случайных чисел в диапазоне от 1 до 100. Длина
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?