В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
arun3
arun3
28.09.2022 22:39 •  Информатика

Напишите программу, которая будет 5 раз генерировать два случайных числа от 1 до 10 и сохранять их в переменные x и y. После этого, программа будет спрашивать у пользователя сумму двух переменных x и y.

Если пользователь отвечает правильно, то программа начисляет ему Иначе она будет просто выводить правильный ответ.

Не забудь вывести итоговый счет, ведь всем интересно насколько хорошо они отвечали

Ответ:
eubvfh
eubvfh
02.07.2021 18:38

import random

score = 0

for i in range(5):

   x = random.randint(1, 10)

   y = random.randint(1, 10)

   print("Введите сумму")

   inp = int(input())

   if x + y == inp:

       print("Верно!")

       score += 1

   else:

       print("Правильный ответ -", x + y)

print("Итоговый счёт:", score)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?