В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Вмассиве из 10 целых чисел подсчитать сумму элементов, стоящих правее минимального.написать программу на языке паскаль., .

Ответ:
liliannaklochko
liliannaklochko
22.06.2020 15:04
Var a: array [1..10] of Integer;
    i, min, sum: integer;
begin
     for i := 1 to 10 do
     begin
          a[i] := random(50);
          writeln('[', i, '] => ', a[i]);
     end;
          min := a[1];
     for i := 2 to 10 do
          if (min > a[i]) then min := a[i];
     i := 1;
     while ((i <= 10) and (a[i] <> min)) do
     begin
           sum := sum + a[i];
           inc(i);
     end;
     writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?