Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Jeembo23
01.05.2022 09:26 •
Информатика
Составить легкую программу! зеркально отразить последовательность в одномерном массиве. т.е. задаем последовательность, вводим границы "зеркала" - х и у. и зеркально отражаем. пример: 12345678910 х=5 у=8 вывод: 12348765910. буду блгодарна!
Ответ:
Diana15007
21.06.2020 12:44
var a: array [1..10] of integer;
i, x, y, xi, yi, t: integer;
begin
for i := 1 to 10 do
readln(a[i]);
writeln('X, Y');
readln(X, Y);
for i := 0 to abs(round(0.5*(x-y))) do
begin
t := a[x+i];
a[x+i] := a[y-i];
a[y-i] := t;
end;
for i := 1 to 10 do
writeln('[', i, '] => ', a[i]);
end.
0,0
(0 оценок)
Ответ:
IFender
21.06.2020 12:44
Вот, пингвинчик :3 Можно было и короче, переменных поменьше и циклов... Но раз задача именно такая, то лучше не сокращать, а то могут оценку снизить)
var a: array [1..10] of integer;
i, x, y, xi, yi, t: integer;
begin
for i := 1 to 10 do
readln(a[i]);
writeln('X, Y');
readln(X, Y);
for i := 1 to 10 do
begin
if (a[i] = X) then xi := i;
if (a[i] = Y) then yi := i;
end;
t := a[xi];
a[xi] := a[yi];
a[yi] := t;
for i := 1 to 10 do
writeln('[', i, '] => ', a[i]);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
pashalol3
08.04.2020 12:24
СОР по информатике. посчитай сколько выйдет средний у Шакенова Т. напиши формулу и адрес ...
Septarik
22.07.2022 17:35
Написать программу паскаль -перенести первое число в конец число трехзначное : )...
Wolceme
02.03.2020 00:20
5. чему равно значение выражения: (1234 div 10) mod 2? 1. 1 2. 3 3. 4 4. 2...
TanNam123
03.01.2023 21:38
Какой операнд пропущен в следующем отрывке кода a: =7; b: =3; a b*2 then f: =0; writeln(f); else while case if...
PIPL34linka
03.01.2023 21:38
Какое значение будет иметь переменная а после выполнения следующего кода: a: =4; b: =2; a: =a*a*b; b: =a+b; 1. 32 2. 34 3. 18 4. 16...
sogoyantigran
26.05.2021 11:55
1. какое значение не может принимать переменная х если она объявлена таким образом: var x: integer 1. 5 2. 12000 3. 8,6 4. 30246...
Ембергенова
29.02.2020 02:14
S=1+1/2+1/3+1/4++1/n pascal. решить с циклом while...
antstuart
29.02.2020 02:14
Напишите информацию все самое интересное о 3d мире . умоляю. нужно...
228апимпрорпрмирир
04.12.2020 14:21
какое значение получит логическая переменная t (true или false), если a=true, b=false? t=(a and b) or not a....
isaev40daniil14
02.10.2021 06:29
С, . с++ дана строчка. вывести слова строчки в обратном порядке....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i, x, y, xi, yi, t: integer;
begin
for i := 1 to 10 do
readln(a[i]);
writeln('X, Y');
readln(X, Y);
for i := 0 to abs(round(0.5*(x-y))) do
begin
t := a[x+i];
a[x+i] := a[y-i];
a[y-i] := t;
end;
for i := 1 to 10 do
writeln('[', i, '] => ', a[i]);
end.
var a: array [1..10] of integer;
i, x, y, xi, yi, t: integer;
begin
for i := 1 to 10 do
readln(a[i]);
writeln('X, Y');
readln(X, Y);
for i := 1 to 10 do
begin
if (a[i] = X) then xi := i;
if (a[i] = Y) then yi := i;
end;
t := a[xi];
a[xi] := a[yi];
a[yi] := t;
for i := 1 to 10 do
writeln('[', i, '] => ', a[i]);
end.