Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Septarik
22.07.2022 17:35 •
Информатика
Написать программу паскаль -перенести первое число в конец число трехзначное : )
Ответ:
marina02427
20.06.2020 19:52
var a, b, c, d: integer;
begin
readln(d);
a := d div 100;
b := d mod 100 div 10;
c := d mod 10;
writeln(b, c, a);
end.
можно ещё сократить:
var a, b, c, d: integer;
begin
readln(d);
writeln(d mod 100 div 10, d mod 10, d div 100);
end.
или даже:
var a, b, c, d: integer;
begin
readln(d);
a := d div 100;
writeln(d - a * 100, a);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
dddddq
25.06.2022 12:21
Чему равно логическое выражение av¬a?...
sestrichkitv
20.07.2020 17:08
Найти произведение всех двух значных чисел...
coolpetrov
23.10.2020 09:03
что делать если падает фпс в гта 5 на компьютере 1060 6 гб, xeon e3 1270,8gb ram...
КсЮшЕнЬкА1102
07.09.2020 05:50
Три группы школьников посадили деревья вдоль дороги. первая группа посадила 35% всех имевшихся деревьев, вторая - 60 % оставшихся деревьев, а третья группа - остальные 104...
ivannaprokuror
07.09.2020 05:50
Простая или сложная форма будущего времени. скоро они побагровеют на морозе...
marishokmarisho
07.09.2020 05:50
Плотное движение транспротных средств...
begem0tcs
07.09.2020 05:50
Охарактеризуйте этапы освободительной борьбы горцев...
диана2473
07.09.2020 05:50
Что изменилось в отнашениях базарова и аркадьем...
hikkaxxx
07.09.2020 05:50
Сочинение по языку 4 части на тему человек которым я восхищаюсь...
sevenfoldblood
07.09.2020 05:50
Первый рабочий выполняет заказ за 15 часов, а второй за 10. сколько времени они потратят, чтобы выполнить заказ вместе?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
readln(d);
a := d div 100;
b := d mod 100 div 10;
c := d mod 10;
writeln(b, c, a);
end.
можно ещё сократить:
var a, b, c, d: integer;
begin
readln(d);
writeln(d mod 100 div 10, d mod 10, d div 100);
end.
или даже:
var a, b, c, d: integer;
begin
readln(d);
a := d div 100;
writeln(d - a * 100, a);
end.