В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DianaSagatbekova
DianaSagatbekova
10.04.2020 16:06 •  Информатика

решить задачу на ПИТОНЕ! Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 2. Кол. Чисел не превышает 1000. Программа должна вывести одно число - максимальное число, оканчивающееся на 2

Ответ:
hgfdui
hgfdui
15.06.2021 16:38

import random

mass = []

masscomp = []

max = 0

for i in range(0, 1000):

   mass.append(random.randint(0, 1000000))

   masscomp = [int(x) for x in str(mass[i])]

   if (mass[i] > max and masscomp[len(masscomp) - 1] == 2):

       max = mass[i]

print(max)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?