Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
AntonovnaAlina200
12.05.2020 22:57 •
Информатика
Ввести с клавиатуры массив из n вещественных чисел. найти разность максимального и минимального элементов. (составить программу pascal)
Ответ:
dostovalovaanast
20.06.2020 10:20
Uses crt;
const
N = 10;
var
a : array [1..N] of Real;
i : Integer;
max, min : Real;
begin
clrscr;
for i := 1 to N do
begin
Write('a[', i,'] = ');
Readln(a[i]);
end;
max := a[1];
min := a[1];
for i := 2 to N do
begin
if max < a[i] then max := a[i];
if min > a[i] then min := a[i];
end;
Writeln(max - min:0:3);
Readln;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Maagistr
24.11.2022 08:17
Вкоробке лежит восемь карандашей.в коробке лежит восемь карандашей. все разного цвета. наугад вынимают один. какой информационный объем в битах сообщения о событии вынутый карандаш...
tyupina2018
25.07.2020 15:10
1.наберите слово Осень в ячейке А5. Удалите это слово из ячейки. 2.Наберите число 585855 в ячейке В5. Скопируйте это число в ячейку Е8. 3.Наберите 2017 год ноябрь месяц в ячейке...
Aisezim2002
13.02.2020 17:17
решить задание ИКТ проанализируйте схему, приведенную на следующем рисунке, и запишите формулу для функции f...
vaflya2007
28.03.2020 21:07
Через 10 минут сдавать на питоне ! имеется n кг металлического сплава. из него изготавливают заготовки массой k кг каждая. после этого из каждой заготовки вытачиваются детали...
fatimo4kkkka
29.08.2022 14:59
Дана переменная n. составьте программу, увеличивающую значение переменной n на единицу, если эта переменная положительная и уменьшить на единицу, если переменная n отрицательная....
Mozgovoi1
30.07.2021 18:52
Объясните своими словами что такое носитель информации какие носители информации вам известны каким носителем информации вы пользуетесь чаще всего...
Kursova82
30.07.2021 18:52
Пятнадцатое мая найдите корень суфикс окончание приставку и т.б...
Danelpos
30.07.2021 18:52
Виведіть молекулярну формулу вуглеводню масова частка гідрогену становить 18,2% відносна молекулярна маса речовини дорівнює 44....
Ivankozyr69gmail
30.07.2021 18:52
Особенности прямокрылых, подёнок тараканов. заранее...
Якoрь
30.07.2021 18:52
Решить пример уменьшаемое 37, вычитаемое 7+13...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const
N = 10;
var
a : array [1..N] of Real;
i : Integer;
max, min : Real;
begin
clrscr;
for i := 1 to N do
begin
Write('a[', i,'] = ');
Readln(a[i]);
end;
max := a[1];
min := a[1];
for i := 2 to N do
begin
if max < a[i] then max := a[i];
if min > a[i] then min := a[i];
end;
Writeln(max - min:0:3);
Readln;
end.