В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
BlackDiamondIce
BlackDiamondIce
30.11.2020 04:24 •  Информатика

Программирование в с++. в массиве в(12) все нецелые элементы из отрезка [a,b] занесите в массив с и найдите минимальный элемент массива с.

Ответ:
nbibyf2005
nbibyf2005
20.06.2020 07:56
Как я понял то а и b - это индексы начала и конца перебора данного массива, если это так то решение таково :
#include <iostream>
using namespace std;
 int main()
{
int B[12];
for(int i=0;i<12;i++)
cin>>B[i]; //занесение в первоначальный массив В
int a,b;
cin>>a>>b; //считывание необходимого промежутка
int C[b-a]; //обьявление конечного массива
for(int i=b-a,k=0;i<b;i++,k++)
{
С[k]=B[i]; // перенос нужных значений
}
int min=C[0]; //переменная в которой будет в итоге храниться минимальное знач.
for(int i=0;i<(b-a);i++)
{
if(C[i]<min) //нахождение минимального элемента
min=C[i];
}
cout<<min; //вывод минимального элемента
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?