В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
matveq888
matveq888
30.01.2023 18:26 •  Информатика

Составить программу для нахождения 1 наименьшего из 4 чисел, после чего умножить его на 2

Ответ:
Грамотейка1
Грамотейка1
26.04.2021 20:00

uses crt ;

function min ( a , b :real ) :real;

begin

if a<b then min := a

else min := b ;

end;

var x , y , z , t :real;

begin

clrscr ;

writeln ( 'Введите 4 числа:' ) ;

readln ( x , y , z , t ) ;

write ( 'Минимальное=' , min( min( x , y ) , min( z , t )) : 0 : 2 ) ;

0,0(0 оценок)
Ответ:
лала123451
лала123451
26.04.2021 20:00

Приведу пример на Haskell

main :: IO ()main = do  a <- read $ getLine :: IO Int  b <- read $ getLine :: IO Int  c <- read $ getLine :: IO Int  d <- read $ getLine :: IO Int  print $ 2 * minimum [a, b, c, d]
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?