В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vladkorkin75
vladkorkin75
02.02.2023 20:28 •  Информатика

Нужно написать программу цикла с параметром в паскале по задаче : Задана последовательность из n вещественных чисел. определить количество элементов последовательности, попадающих в заданный интервал (a,b)/

Ответ:
volden05
volden05
19.05.2021 18:11

var

 x,a,b:real;

 i,n,count:integer;

begin

 count:=0;

 write('Интервал(a,b): '); readln(a,b);

 write('Кол-во чисел в посл.: '); readln(n);

 for i:=1 to n do

   begin

     readln(x);

     if (x>a) and (x<b) then

       inc(count);

   end;

 writeln('Кол-во в интерв.:',count);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?