Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
aruka10511
24.02.2022 04:18 •
Информатика
на c++ дан массив ненулевых целых чисел. определить, сколько раз элементы массива при просмотре от его начала меняют знак. например, в массиве 10, -4, 12, -4, -89, знак меняется три раза на c++
Ответ:
DanaCorgi
19.06.2020 10:39
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;
int main()
{
srand (time(NULL));
int a[10],k = 0;
for (int i = 0; i<10; i++)
{
do
{
a[i] = rand()%20-10;
}
while (a[i]==0);
cout <<a[i] <<" ";
}
cout <<endl;
for (int i = 0; i<9; i++)
if ((a[i]>0 && a[i+1]<0) || (a[i]<0 && a[i+1]>0))
++k;
cout <<"Kol-vo: " <<k <<endl;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
iDanee
27.04.2020 03:58
Задача 1: Вычисление степени При языка программирования Питон определите значение выражения 3 в степени 100. Какое число получилось? Напишите программу, вычисляющую это значение,...
StayStr0g
19.09.2022 17:31
1.постройте таблицу истинности для заданной логической функции f(p,q,r)=p& qvr& p, при p=02.постройте функциональную схему для функции f(p,q,r) из 1...
ekicinurzulal
30.08.2020 01:04
По м о г и т е, п о ж а л у й с т а! 1) с датчика случайных чисел получить 15 вещественных чисел n (38...
faire6
16.02.2020 06:09
Придумайте девиз для клана под названием Уточки....
morcowqwerty
07.04.2022 13:25
3. Дана программа: Program Pri; Var a, integer; Begin ReadLn (a); ReadLn (b) ; а:=a*a; b:=b *b; WriteLn(a); WriteLn (b); End. Определите, какая задача решается данной программой....
Filka7
26.05.2021 00:47
ПО ИНФОРМАТИКЕ, ВСЕ ВОПРОСЫ НА ФОТО...
vikaMiwka
27.09.2021 05:37
Найдите решение уравнений 1273...
Sonya45138
27.09.2021 05:37
Удалите все мои последние вопросы ...
egorkashoshin0
24.08.2022 15:41
К.р по русскому языку тема(наречие как часть речи) 7. В каком словосочетании наречие имеет значение признака другогопризнака?а) идти впередВ) кофе по-турецки;б) мало-помалу...
elyukros
01.06.2022 07:00
Начерти многоугольники в тетради,пронумеруй их и закрась,заполни таблицу....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <ctime>
#include <cstdlib>
using namespace std;
int main()
{
srand (time(NULL));
int a[10],k = 0;
for (int i = 0; i<10; i++)
{
do
{
a[i] = rand()%20-10;
}
while (a[i]==0);
cout <<a[i] <<" ";
}
cout <<endl;
for (int i = 0; i<9; i++)
if ((a[i]>0 && a[i+1]<0) || (a[i]<0 && a[i+1]>0))
++k;
cout <<"Kol-vo: " <<k <<endl;
return 0;
}