В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
morcowqwerty
morcowqwerty
07.04.2022 13:25 •  Информатика

3. Дана программа: Program Pri;
Var a,
integer;
Begin
ReadLn (a); ReadLn (b) ;
а:=a*a; b:=b *b;
WriteLn(a); WriteLn (b);
End.
Определите, какая задача решается данной программой.
Что будет выведено на экран при вводе значений: а = 9,
b = 10?

Ответ:
тати31
тати31
21.11.2020 06:34

81

100

Объяснение:

Программа получает на вход 2 целых числа:

ReadLn (a); ReadLn (b)

Возводит их в квадрат (умножает число на себя):

а:=a*a; b:=b *b;

Выводит получившиеся значения на экран с новой строки:

WriteLn(a); WriteLn (b);

а = 9      а = 9 * 9 = 81    

b = 10      b = 10 * 10 = 100

в программе пропущена часть объявления переменных, должно быть так Var a,b:integer;

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?