В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alenayugova26Alena
alenayugova26Alena
14.11.2021 03:56 •  Информатика

Нужно написать программу на языке Python


Нужно написать программу на языке Python
Нужно написать программу на языке Python

Ответ:
Kamilla1351
Kamilla1351
27.04.2021 18:54

import random

matrix = []

subarray = []

dim_m = int(input("Input amount of rows"))

dim_n = int(input("Input amount of columns"))

rand_gen_top = int(input("Input random generation max value"))

rows_avg_list = []

cols_avg_list = []

rows_avg = 0

cols_avg = 0

for i in range(0, dim_n, 1):

   for j in range(0, dim_m, 1):

       subarray.append(random.randint(0, rand_gen_top))

       rows_avg += subarray[j]

   matrix.append(subarray)

   rows_avg_list.append(rows_avg / dim_m)

   subarray = []

   rows_avg = 0

for j in range(0, dim_m, 1):

   for i in range(0, dim_n, 1):

       cols_avg += matrix[i][j]

   cols_avg_list.append(cols_avg / dim_n)

   cols_avg = 0

print("\nMatrix dimension m =", dim_m)

print("\nMatrix dimension n =", dim_n)

print("\nRange of random generated numbers from 0 to:", rand_gen_top)

print("\nMatrix A:\n")

for i in range(0, dim_m, 1):

   print(matrix[i])

print("\nAverage in rows:", rows_avg_list)

print("\nAverage in columns:", cols_avg_list)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?