В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
NasFan
NasFan
02.03.2020 19:37 •  Информатика

Напишите программу, которая считывает с клавиатуры два целых числа и строку.Если эта строка является обозначением одной из четырѐх математических операций (+, -, *,/), то выведите результат применения этой операции к введѐнным ранее числам, в противном случае выведите «Неверная операция». Если пользователь захочет поделить на ноль, выведите текст«На ноль делить нельзя!».На вход программе подаются два целых числа, каждое на отдельной строке, и строка.Программа должна вывести результат применения операции к введенным числам или соответствующий текст, если операция невернаялибо если происходит деление на ноль.

Ответ:
Диа773
Диа773
15.04.2021 18:48

Python:

while True:

 try:

   a = int(input('Введите a: '))

   break

 except ValueError:

   print('Вводите целое число!')

while True:

 try:

   b = int(input('Введите b: '))

   break

 except ValueError:

   print('Вводите целое число!')

c = input('Введите действие (+,-,*,/): ')

if c == '+': print(a+b)

elif c == '-': print(a-b)

elif c == '*': print(a*b)

elif c == '/':

 if b != 0: print(a/b)

 else: print('На ноль делить нельзя')

else: print('Неверная операция')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?