В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
astanina042
astanina042
27.10.2021 01:06 •  Информатика

Составить программу: дан массив из 40, из него составить два массива, первый с четными положительными числами, а второй с остальными. рандом (-1000..1000) в паскале

Ответ:
lisinpetr2014
lisinpetr2014
04.10.2020 19:54
Const n=40;
var a,b,c:array [1..n] of integer;
i,i1,i2:integer;
begin
randomize;
for i:=1 to n do
 begin
 a[i]:=random(2001)-1000;
 write(a[i],' ');
 end;
writeln;
i1:=0; i2:=0;
for i:=1 to n do
 if (a[i] mod 2 = 0)and(a[i]>0)
  then begin i1:=i1+1; b[i1]:=a[i]; end
  else begin i2:=i2+1; c[i2]:=a[i]; end;
for i:=1 to i1 do write(b[i],' ');
writeln;
for i:=1 to i2 do write(c[i],' ');
writeln;
end.

Пример (для n=10):
46 -695 764 502 965 253 454 180 -123 980 
46 764 502 454 180 980 
-695 965 253 -123 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?