В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kam09
Kam09
05.10.2021 15:30 •  Информатика

2) Необходимо написать программу, которая на Вход получает 3 числа, после этого выводится на
экран число, полученное следующим образом: к
среднему арифметическому значению чисел
прибавляется число, которое в 2 раза меньше
разницы максимального от минимального.

ОЧЕНЬ НАДО​

Ответ:
dongrigoriew20
dongrigoriew20
15.04.2021 14:53

#include <iostream>

using namespace std;

int min(int v, int w){

   if (v > w){

       return w;

   }else{

       return v;

   }}

int minimum(int a, int b, int c){

   int min1, min2;

   min1 = min(a,b);

   min2 = min(min1,c);

   return min2;

}

int max(int v, int w){

   if (v > w){

       return v;

   }else{

       return w;

   }}

int maximum(int a, int b, int c){

   int max1, max2;

   max1 = max(a,b);

   max2 = max(max1,c);

   return max2;

}

int main() {

int a, b , c , d,min3,max3,e;

cin >> a >> b >> c;

min3 = minimum( a, b, c);

max3 = maximum( a, b, c);

e =  (max3 - min3 )/2;

d = (a + b + c)/3;

cout << d + e;

}

Объяснение:

решение на с++

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?