В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
katya022
katya022
28.06.2022 13:35 •  Информатика

Решите сегодня на языке python Совпадающие начало и конец
Дана строка. Требуется найти самую длинную её подстроку, у которой совпадает первый и последний символы. Если подходит несколько подстрок, то выведите любую из них.

Входные данные

На вход подаётся одна строка из строчных латинских букв длиной не более 100 символов.

Выходные данные

Выведите ответ на задачу.

Ответ:
0Ева002
0Ева002
14.04.2021 22:10

s = input()

ans = ''

for i in range(len(s)):

   j = s.rfind(s[i]) + 1

   if j - i > len(ans):

       ans = s[i:j]

print(ans)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?