В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
юра416
юра416
10.05.2021 00:59 •  Информатика

Напишите программу которая меняет местами две соседних элемента списка (а[0] и а[1],а[3]... и т.д.). Если количество элементов нечётное,то последнее число должно оставаться на месте питон ​

Ответ:
bandit12341
bandit12341
05.03.2021 18:00

a = [int(i) for i in input().split()]

for i in range(1, len(a), 2):

   a[i - 1], a[i] = a[i], a[i - 1]

print(' '.join([str(i) for i in a])

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?