В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sofka11123
Sofka11123
02.06.2022 10:37 •  Информатика

Написать программу, которая подсчитывает количество четных индексов положительных элементов введенного с клавиатуры массива целых чисел.

Ответ:
masha32434
masha32434
17.06.2020 20:23

var

  a:array [1..100] of integer;

  i,n,k:integer;

begin

  write ('Razmer massiva: ');readln(n);

  k:=0; 

  for i:=1 to n do begin

    write ('A[',i,'] = ');readln(a[i]);

    if (a[i]>0) and (i mod 2 = 0) then k:=k+1;

  end;

  writeln ('Kol-vo: ',k);

  readln;

end.

0,0(0 оценок)
Ответ:
kykapeka227
kykapeka227
17.06.2020 20:23

a - массив из n элементов
k - количество четных индексов положительных элементов
i - цикловая переменная, также индекс элемента массива
Язык программирования: Паскаль

var
a : array [1..100] of integer;
n, k, i : integer;
begin
k := 0;
readln (n);
for i:=1 to n do
begin
readln (a [ i ]);
if (i mod 2 = 0) and (a [ i ] > 0) then
k := k + 1;
end;
writeln (k);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?