В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
winterwhite123
winterwhite123
20.08.2022 00:07 •  Информатика

Составить программу в pascalabc, которая запрашивает ввод буквы латинского алфавита, а потом для данной буквы напечатает справа стоящую букву на стандартной клавиатуре. при этом считается, что справа от буквы "p" стоит буква "a", от буквы "l" стоит буква "z", от буквы "m" стоит буква "q".

Ответ:
Gggggggggggg22
Gggggggggggg22
13.08.2020 14:20
// PascalABC.NET 3.0, сборка 1073
const
  s='';
var
  c:char;
  p:integer;
begin
  repeat
    Write('Введите латинскую букву, иной символ завершит работу: ');
    Readln(c);
    p:=Pos(c,s);
    if p>0 then Writeln('Рядом буква "',s[p+1],'"')
  until p=0
end.

Тестовое решение:
Введите латинскую букву, иной символ завершит работу: y
Рядом буква "u"
Введите латинскую букву, иной символ завершит работу: H
Рядом буква "J"
Введите латинскую букву, иной символ завершит работу: m
Рядом буква "q"
Введите латинскую букву, иной символ завершит работу: P
Рядом буква "A"
Введите латинскую букву, иной символ завершит работу: 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?