В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Maksat3232123
Maksat3232123
14.09.2021 22:05 •  Информатика

Написать программу выводящею матрицу 11111 01110 00100 01110 11111

Ответ:
vikailen
vikailen
17.06.2020 19:51

Можно обойтись без массива и этим сэкономить память компьютера.

Можно также вывести такую матрицу (в виде песочных часов) любого размера. Для этого нужно только изменить значение n в строке

const n=5

 

Program Pentelemon;
uses crt;
const n=5;
var
 i,j:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  for i:=1 to n do
    begin
      for j:=1 to n do
        begin
          if ((j>=i) and (i+j<=n+1)) or ((j<=i) and (i+j>=n+1)) then
              write ('1 ')
            else
              write ('0 ');
        end;
      writeln();
    end;
end.

0,0(0 оценок)
Ответ:
MrHard1
MrHard1
17.06.2020 19:51

var

  a:array [1..5,1..5] of integer;

  i,j:integer;

begin

  for i:=1 to 5 do begin

   for j:=1 to 5 do begin

    if ((j>=i) and (i+j<=6)) or ((j<=i) and (i+j>=6)) then a[i,j]:=1 else a[i,j]:=0;

    write (a[i,j]:3); 

   end;

   writeln;

  end;

  readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?