В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Америя
Америя
04.11.2020 12:34 •  Информатика

Составить программу c++ для вычисления значения выражения: при следующих исходных данных: a=0,9 b=12,5 переменную x задать с клавиатуры. (c проверкой знаменателя на 0)

Ответ:
Katyha028272819
Katyha028272819
27.08.2020 12:48

#include <iostream>

#include <cstdlib>

#include <cmath>

using namespace std;

int main()

{

float x, y;

float a = 0.9;

float b = 12.5;

cin >> x;

if(1,6 * pow(a,2) * x + b * log(a) != 0){

 y = (pow(cos(x-1),2) - pow(b,-3)*x)/(1,6 * pow(a,2) * x + b * log(a));

}

cout << "Result: " << y << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?