В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Samisha
Samisha
01.09.2021 14:41 •  Информатика

Составить алгоритм и написать программу вычисления площади фигуры с использованием условного оператора if по одной из формул: s=п*r ; s=a*b

Ответ:
Erosa51
Erosa51
17.06.2020 15:48

var

s,r,a,b:real;

k:byte; 

begin

repeat 

write ('1 - S kruga; 2 - S  pryamougolnika: ');readln(k);

until (k=1) or (k=2); 

if k=1 then begin

write ('Radius: ');readln(r);

s:=pi*r;

writeln ('S = ',s:0:5);

end else begin

write ('A = ');readln(a);

write('B = ');readln(b);

s:=a*b;

writeln ('S = ',s:0:4);

end;

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?