В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vladagabriell
vladagabriell
27.11.2020 04:19 •  Информатика

Напишите программу на Python.
"Найти количество четных цифр заданного натурального числа N."

Ответ:
jendossia
jendossia
27.02.2021 19:20

while True:

 try:

   n = int(input('Введите натуральное число: '))

   break

 except ValueError:

   print('Неверные входные данные. Попробуйте снова.')

n = abs(n)

b = 0

while n>0:

 if n%10%2 == 0:

   b+=1

 n = n//10

print('Количество чётных цифр в ведённом числе равно ' + str(b))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?