В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
пимимпп
пимимпп
24.03.2023 21:59 •  Информатика

Python. Циклы for и while. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). 30 б.

Ответ:
alexlion99alex
alexlion99alex
17.03.2021 22:13

x, s, counter = -1, 0, 0

while x != 0:

   x = int(input())

   if (x>=100) and (x<=999):

       s += x

       counter += 1

if counter == 0:

   print("NO")

else:

   print(s/counter)

0,0(0 оценок)
Ответ:

numbers = []

while True:

   num = int(input('Введите число: '))

   if num == 0:

       break

   if len(str(num)) == 3:

       numbers.append(num)

if numbers != []:

   s = 0

   for num in numbers:

       s += num

   print('Среднее арифметическое:', s / len(numbers))

else:

   print('NO')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?