Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
polilaibe
28.02.2023 23:44 •
Информатика
Дан фрагмент на паскале
A:=1 b:=1
While (a+b)<16 do
begin
a:=a+1; b:=b+2
End;
s:=a+b;
Составьте трассировочную таблицу для данного фрагмента программы. Чему будут равны значения переменных, a, b, s после завершения этой последовательности?
Ответ:
Brain111t
22.12.2023 12:45
Хорошо, давайте приступим к составлению трассировочной таблицы и пошаговому решению этого фрагмента программы.
| Шаг | a | b | (a+b) | a:=a+1; b:=b+2 | s:=a+b |
|-----|---|---|-------|--------------|--------|
| 1 | 1 | 1 | 2 | | |
| 2 | | | | a:=2; b:=3 | |
| 3 | | | | a:=3; b:=5 | |
| 4 | | | | a:=4; b:=7 | |
| 5 | | | | a:=5; b:=9 | |
| 6 | | | | a:=6; b:=11 | |
| 7 | | | | a:=7; b:=13 | |
| 8 | | | | a:=8; b:=15 | |
| 9 | | | | a:=9; b:=17 | |
После завершения последовательности значения переменных будут следующими:
a = 9
b = 17
s = a + b = 9 + 17 = 26
Таким образом, значения переменных после завершения этой последовательности будут:
a = 9, b = 17, s = 26.
0,0
(0 оценок)
Популярные вопросы: Информатика
Стася911
03.02.2023 01:23
Сколько времени будет скачиватся аудиофайл размером 120 кбайт при интернет соединение с максмальной скоростью скачивания 1920 бит/с ответ...
Kdjs
08.08.2021 16:59
1.в чем суть кодирования информации? 2.зачем применяется кодирование при обработки информации? 3.как кодируют символы текста? 4.как кодируют рисунки? 5.как кодируют звук?...
пик124
15.02.2021 23:34
. а) кто такой норберт винер и какова его роль в исследовании информационных процессов? б) кто такой клод шеннон и чем он знаменит? в) кем и когда был введён термин «гипертекст»?...
bahriddinJoN2085
15.02.2021 23:34
Определить 3-ю цифру в записи 6-значного натурального числа. для нахождения 3 цифры надо отрезать от числа последние 3 и первые 2 цифры составить программу ,применяя операции...
tatanavolosnova1
26.05.2023 16:00
Определите значение переменной s после выполнения опера- торов: i: =0; s: =0 while i 5 do begin i: =i+2; s: =s+i*i end;...
Killrog
26.05.2023 16:00
Что выведется на экран в результате выполнения фрагмента программы: p: =1; for k: =1 to 5 do begin p: =p*k; end; write(‘ k=’, k, ’ p=’, p)...
секрет93
01.09.2020 13:40
Почему кегли являются одним из обязательных атрибутов в игре?...
Dan4ik1111111111
30.06.2020 17:52
Чтобы распечатать модель, созданную в 3D-программе,необходимо ее...ВставитьКопироватьэкспортироватьотправить на печать...
Ilona286
13.05.2023 04:00
Программа для превращения трехмерной модели в наборпонятных для принтеракоманд, называемых g-кодом.Слайсер ПринтерСканерПлоттер...
aminayahydinap00uha
06.07.2021 08:46
Напишите программу, которая инвертирует определенный бит в заданном числе (биты при этом нумеруются с 0, начиная с младших)....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
| Шаг | a | b | (a+b) | a:=a+1; b:=b+2 | s:=a+b |
|-----|---|---|-------|--------------|--------|
| 1 | 1 | 1 | 2 | | |
| 2 | | | | a:=2; b:=3 | |
| 3 | | | | a:=3; b:=5 | |
| 4 | | | | a:=4; b:=7 | |
| 5 | | | | a:=5; b:=9 | |
| 6 | | | | a:=6; b:=11 | |
| 7 | | | | a:=7; b:=13 | |
| 8 | | | | a:=8; b:=15 | |
| 9 | | | | a:=9; b:=17 | |
После завершения последовательности значения переменных будут следующими:
a = 9
b = 17
s = a + b = 9 + 17 = 26
Таким образом, значения переменных после завершения этой последовательности будут:
a = 9, b = 17, s = 26.