Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
aminayahydinap00uha
06.07.2021 08:46 •
Информатика
Напишите программу, которая инвертирует определенный бит в заданном числе (биты при этом нумеруются с 0, начиная с младших).
Ответ:
kisaayan
02.10.2020 12:43
Var
n,k:integer;
begin
Write('Укажите число и номер инвертируемого бита: ');
Read(n,k);
Writeln('Результат: ',n xor (1 shl k))
end.
Тестовое решение:
Укажите число и номер инвертируемого бита: 573 4
Результат: 557
0,0
(0 оценок)
Популярные вопросы: Информатика
fara30
25.06.2022 12:50
нужно сделать программу на С....
zzxxccv1
06.04.2021 03:33
Информационная деятельность людей приводит к формированию...
DmitriyTF2
06.08.2022 02:10
У исполнителя Калькулятор две команды, которым присвоены номера: 1. прибавь 2 2. умножь на 3 Сколько есть программ, которые число 1 преобразуют в число 55?...
dimon564557
12.02.2020 13:57
Какие из утверждений верны? а) имя файла всегда короче полного имени файла; б) в операционных системах windows вместо понятия каталог применяют понятие папка; в)...
nkochneva1
18.05.2023 20:40
Заполнить массив случайными числами. найти на сколько максимальный элемент массива больше минимального. надо....
AloysiuS
18.05.2023 20:40
Заполнить массив случайными целыми числами. заменить элементы массива, равные минимальному, числом 99. надо....
steamoff
18.05.2023 20:40
Сколько памяти занимает двоичное число?...
Zein304
24.12.2020 14:25
Назовите при которое отображает работу на компьютере....
ViktorNi
20.02.2022 08:11
Даны 2 массива а и в (элементы рандомятся) как получит массив с чтобы в нем шли вначале элементы из массива а , а после шли элементы из массива b...
Merlin33
20.02.2022 08:11
Впаскале: вычислить произведение всех натуральных чисел от 1 до n (n-любое) использовать оператор for или while....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n,k:integer;
begin
Write('Укажите число и номер инвертируемого бита: ');
Read(n,k);
Writeln('Результат: ',n xor (1 shl k))
end.
Тестовое решение:
Укажите число и номер инвертируемого бита: 573 4
Результат: 557