В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Травка58
Травка58
09.08.2020 01:21 •  Информатика

Решите:
Дано целое трёхзначное число х. Составьте программу вычисления суммы и произведения цифр трёхзначного числа х. Значение х ввести с клавиатуры.
Язык программирования Паскаль

Ответ:
buckubarnes17
buckubarnes17
01.02.2021 01:00

Прости что не текстом :(


Решите: Дано целое трёхзначное число х. Составьте программу вычисления суммы и произведения цифр трё
0,0(0 оценок)
Ответ:
hohotuchka
hohotuchka
01.02.2021 01:00

var

s,pr,x : integer;

begin

readln(x);

x := abs(x);

s:= 0;

pr:= 1;

while x > 0 do

begin

s := s + x mod 10;

pr := pr * x mod 10;

x:= x div 10;

end;

writeln('S = ',s);

writeln('PR = ',pr);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?