В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

1)составьте программу вычисления в массиве а, содержащего n элементов, произведения положительных чисел. pascal 2)составьте программу вычисления суммы элементов от первого отрицательного и до конца. pascal

Ответ:
strekoza7
strekoza7
15.06.2020 03:03

program massiv1;

uses CRT;

var i,N,P:integer;

a:array [1..N] of integer;

begin

P:=1;

read(N);

for i:=1 to N do

begin

read a[i];

end;

for i:=1 to N do

begin

if  a[i] >o 

then

P:=P*a[i];

end;

write(P);

readkey;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?