В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Доо43
Доо43
14.07.2021 01:39 •  Информатика

Составить программу, которая посчитает високосные года с 1990 по 2021, если первый високосный год 1992.

Ответ:
marschmello
marschmello
18.02.2021 13:15

1990 - Невисокосный

1991 - Невисокосный

1992 - Високосный

1993 - Невисокосный

1994 - Невисокосный

1995 - Невисокосный

1996 - Високосный

1997 - Невисокосный

1998 - Невисокосный

1999 - Невисокосный

2000 - Високосный

2001 - Невисокосный

2002 - Невисокосный

2003 - Невисокосный

2004 - Високосный

2005 - Невисокосный

2006 - Невисокосный

2007 - Невисокосный

2008 - Високосный

2009 - Невисокосный

2010 - Невисокосный

2011 - Невисокосный

2012 - Високосный

2013 - Невисокосный

2014 - Невисокосный

2015 - Невисокосный

2016 - Високосный

2017 - Невисокосный

2018 - Невисокосный

2019 - Невисокосный

2020 - Високосный

2021 - Невисокосный

P.S. Программа на языке Python:

for year in range(1990, 2022):

   if (year % 4 == 0 and year % 100 != 0) or (year % 400 == 0):

       print(year,"- Високосный")

   else:

       print(year,"- Невисокосный")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?