В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lren1
lren1
24.04.2020 03:23 •  Информатика

Написать программу, суммирующую положительные элементы массива, полученную сумму возвести в квадрат (сделать через pascal)( надо ни то 2 поставят)

Ответ:
chery10
chery10
07.07.2020 12:06
Const  n = 10;  var  a :array [1..n] of integer;  i, sum :integer;
begin
  for i:= 1 to n do    readln(a[i]);    sum:= 0;  for i:= 1 to n do    if a[i] > 0 then      sum:= sum + a[i];  sum:= sqr(sum);  writeln(sum);      end.
0,0(0 оценок)
Ответ:
ntisdeil2010
ntisdeil2010
07.07.2020 12:06
Const N = 10;
Var i,S:integer; m:array [1..N] of integer;
Begin       
Writeln('Введите массив');       
for i:=1 to 10 do begin       
readln(m[i]);       
if m[i]>0 then S:=S+m[i]; end;       
S:=sqr(S);       
writeln('Сумма^2 равна ',S);       
readln;       
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?