В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Xb000
Xb000
27.05.2023 09:03 •  Информатика

Синформатикой. 7 класс. turbo pascal №1: составить программу, которая преобразует введённое с клавиатуры дробное число в денежный формат (12.5 в 12 рублей 50 копеек). a - исходные данные x,y - результаты trunc (12,5)=12 frac (12,5) =0.5 0.5*100=50.0 trunc (50.0)=50 №2: составить программу, вычисляющую сумму цифр трёхзначного числа n. n - трёхзначное число (напр.762) - исходные данные a,b,c - цифры этого числа №3: программа находит из а и в большее. а,b - исходные c - результат №4: с кондитерской фабрики разгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. какое наименьшее количество коробок потребуется для перевозки n килограмм конфет? №5: int(-5,89) int(0,53) round(-5,8) round(5,2) frac(-17,4) frac(0,32) trunc(-17,4) trunc(15,2) 45 div 4 15 mod 8 (489 div 10) mod 10

Ответ:
fbgudcc
fbgudcc
14.06.2020 20:17

1)

var

  a: real;

  x, y: integer;

 

begin

  writeln('Введите дробное число');

  readln(a);

  x:= trunc(a);

  y:= frac(a);

  writeln(x, ' рублей ', y * 100, ' копеек');

  readln;

end.

2)

var

  n: 100..999;

  a, b, c: 0..9;  //a - сотни, b - десятки, с - единицы

 

begin

  writeln('Введите трехзначное число');

  readln(n);

  a:= n div 100;

  b:= (n mod 100) div 10;

  c:= n mod 10;

  writeln('Сумма цифр:  ', a + b + c);

  readln;

end.

3)

var

  a, b, c: real;

 

begin

  writeln('Введите числа а и b');

  readln(a, b);

  if a > b then

  begin

    c:= a;

    writeln(c, ' - большее число');

  end;

  if b > a then

  begin

    c:= b;

    writeln(c, ' - большее число');

  end;

  if b = a then writeln('Числа равны');

  readln;

end.

 

  

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?