В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Tvoyainta
Tvoyainta
21.03.2023 00:35 •  Информатика

ИНФОРМАТИКА. ПАСКАЛЬ(ЯЗЫК ПРОГРАММИРОВАНИЯ) Задача 1. Создайте программу, определяющую, какой сейчас сезон по введённой температуре воздуха:от 0 до -30 0С – зима; от +20 до +40 0С – лето; иначе (от +1 до +19 0С) - весна или осень.

Задача 2. Составить программу, вычисляющую стоимость покупки с учетом скидки: если покупка превышает 1500 р., то начисляется скидка 3%, если превышает 2000, то начисляется скидка 5%. Выше 4000 - скадка 7%. На вход - стоимость покупки, выход - сколько нужно оплатить.

Решать по такому типу:

a,b,c:integer;
begin
writeln('Введите три числа: '); readln(a,b,c);
if (a>b) and (b>c) then
writeln(a,b,c);
if (a>b) and (b>c) then writeln(c,b,a);
if (a>c) and (c>b) then writeln(b,c,a);
if (b>a) and (a>c) then writeln(c,a,b);
if (b>c) and (c>a) then writeln(a,c,b);
if (c>a) and (a>b) then writeln(b,a,c);
if (c>b) and (b>a) then writeln(a,b,c);
end.

Ответ:
wormer221
wormer221
18.01.2021 12:50

первая задача ответ-var x: real;

begin

writeln('введите температуру');

readln(x);

if (x>=-30) and (x<=0) then writeln('зима')else

if (x>=20) and (x<=40) then writeln('лето') else

writeln('весна или осень')

end.

Объяснение:

думаю правельно

0,0(0 оценок)
Ответ:
Spudi14
Spudi14
18.01.2021 12:50

тут нада зробити у програмі Рутсон и написати оце потім візьмеш нажмеш ран и побачиш результат

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?