В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

написать программу на С++ Ввести в 3 переменные строкового типа s1,s2,s3 ваши фамилию, имя отчество. Переставить местами значения 3-х переменных, так чтобы в s1 оказалось значение s2, в s2 - значение s3, в s3 - прежнее значение s1.

Ответ:
valeria02042004
valeria02042004
15.02.2021 18:58

Объяснение:

#include <iostream>

#include <string>

using namespace std;

int main()

{

   string s1="Петров", s2="Иван", s3="Алексеевич", temp;

   temp = s1; //присваиваем значение s1 временной переменной temp

   s1 = s2;

   s2 = s3;

   s3 = temp;

   

   cout << s1 << s2 << s3 <<;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?