В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ViktoriaTo
ViktoriaTo
26.05.2021 08:09 •  Информатика

Язык желательно си, но можно любой. Дан массив A из 2×N элементов. Требуется поменять местами значения во всех парах в массиве A: значение первого со значением второго, значение третьего со значением
четвертого, ..., значение предпоследнего со значением последнего.
Input
Со стандартного устройства ввода в первой строке вводится целое число
N (1 <= N <= 1000) — количество пар элементов массива. Во второй строке через пробел
вводятся 2×N целых чисел — элементы массива A (-1000 <= Ai <= 1000).
Output
Требуется вывести получившийся после обменов массив A. Выводить пробел в конце
строки пробел не нужно.
Sample Input
3
2 3 4 6 8 21
Sample Output
3 2 6 4 21 8

Ответ:
Vladttttt
Vladttttt
12.02.2021 22:13

#include <iostream>

using namespace std;

int main()

{

   int n;

   cin>>n;

   int arr[static_cast<const int>(n)][2];

   for(int i = 0;i<n;i++){

       for(int j = 0;j<2;j++){

           cin>>arr[i][j];

       }

   }

   for(int i = 0;i<n;i++){

       for(int j = 1;j>=0;j--){

           cout<<arr[i][j]<<" ";

       }

   }

   return 0;

}

static_cast<const int>(n) - Эта функция преобразовывает n в константу.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?