В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aicha21
aicha21
19.03.2020 05:59 •  Информатика

решить задачу на Питоне, Рекурсия Задача
Напишите программу, содержащую рекурсивную функцию, которая по натуральному числу n, выводит все числа от n до 1. Основная программа должна содержать ввод исходных данных (число n) и вызов функции

Примеры
№ Входные данные Выходные данные
1 6 6 5 4 3 2 1
Запрещенные операторы: for;while;until

Ответ:
Ученик132312
Ученик132312
29.11.2020 01:08

def allnumbers(n):

   if n == 0:

       return 1

   print(n, end=' ')

   allnumbers(n - 1)

n = int(input("Введите число n: "))

allnumbers(n)

Объяснение:

def allnumbers(n):  // Функция allnumbers, которая принимает аргумент n

   if n == 0:  // Если значение переменной n = 0

       return 1  // Выходим из функции

   print(n, end=' ')  // Выводим значение переменной n

   allnumbers(n - 1)  // Рекурсия

n = int(input("Введите число n: "))  // Вводим число n с клавиатуры

allnumbers(n) // Функция

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?