В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
арсюха6
арсюха6
18.12.2020 10:08 •  Информатика

Нужно написать программу на Python которая будет выводить числа от 0 до X (число X введет пользователь) сперва в порядке возрастания, а потом в порядке убывания. Каждое число должно быть в новой строчке. Пример:
Пользователь ввел число 5. Программа выводит:
0
01
012
0123
01234
012345
01234
0123
012
01
0

Ответ:
mirvera2007
mirvera2007
12.02.2021 21:46

x = int(input())

s = '0'

for i in range(1,x+2):

   print(s)

   s += str(i)

for i in range(2,len(s)):

   print(s[:-i])

#с наступающим)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?