В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Iana2010
Iana2010
17.02.2022 02:33 •  Информатика

Напишите программу, которая определит, каких символов в последовательности
больше: четных или нечётных? Числа вводятся до ввода нуля.

Ответ:
katizhi
katizhi
19.01.2021 17:02

ch,nch = 0,0

x = int(input())

while x != 0:

   if x != 0 and x % 2 == 0:

       ch += 1

   else:

       nch += 1

   x = int(input())

if ch > nch:

   print("Четных больше")

elif nch > ch:

   print("Нечетных больше")

else:

   print("Одинаково")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?