В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
toyru556
toyru556
10.04.2021 21:52 •  Информатика

Вычислить сумму положительных и произведение отрицательных элементов массива написать программу в паскале

Ответ:
Slrudyko
Slrudyko
24.05.2020 11:48

var a: array [1..10] of integer;

      s,s1,i: integer;

begin

  s:=0;

  s1:=1;

  for i:=1 to 10 do 

    begin

      readln(a[i]);

      if a[i]>0 then s:=s+a[i];

      if a[i]<0 then s1:=s1*a[i];

    end;

  writeln('Сумма: ',s,', произведение: ',s1);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?