В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
antstuart
antstuart
23.03.2022 01:45 •  Информатика

Можно программу на языке паскаль ":) Составить программу нахождения суммы всех делителей заданного натурального числа N.
(Само число и единица включаются в число делителей.)

Формат входных данных
Входной файл содержит число N (1≤N≤1000).

Формат выходных данных
Выведите искомую сумму.

Примеры:
Вход
3
Выход
4

Ответ:
Shiro228
Shiro228
12.01.2021 13:36

var sum,i,N:integer; t,t1:text;

begin

 assign (t, 'input.txt'); reset(t);

 assign (t1, 'output.txt'); rewrite(t1);

read(t,N);

sum:=0;

for i:=1 to N do

 if N mod i = 0 then sum:= sum+i;

write(t1,sum);

close(t1)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?