В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vikamurzikk
Vikamurzikk
19.04.2021 01:16 •  Информатика

Напишите программу, которая оценит справедливость конспирологического тарифа. Из списка чисел нужно выбрать те, что имеют ту же чётность, что и минимальное.

Формат ввода
Вводится строка целых чисел, записанных через пробел.

Формат вывода
Вывести числа, которые имеют ту же чётность, что и наименьшее, без повторений, порядок вывода неважен.

Пример 1
Ввод
2 5 17 3 18 6 1 9
Вывод
1 3 5 9 17

Ответ:
temirhanarmy
temirhanarmy
11.01.2021 07:19

a = list(map(int, input().split()))

m = min(a)

res = []

for i in range(len(a)):

   if(a[i]%2==m%2 and a[i] not in res):

       res.append(a[i])

for row in range(len(res)):

   print(res[row], end=' ')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?