В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Язык - Python
Развернуть элементы с нечетными индексами
Вам дан список целых чисел. Разверните элементы с нечетными индексами.
Входные данные
Вводится список чисел. Все числа списка не превосходят по модулю 100 и находятся на одной строке.
Выходные данные
Выведите получившийся список.
Примеры
Ввод
1 2 3 4 5
Вывод
1 4 3 2 5

Ответ:
linagalkinaa1
linagalkinaa1
15.10.2020 14:49

--- Python 3.8.3 ---

RawList = list(map(int, input().split()))

fLen = len(RawList)

HalfLen = fLen//2

for i in range(1, HalfLen+1, 2):

   RawList[i], RawList[fLen-i-1] = RawList[fLen-i-1], RawList[i]

print(*RawList)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?