В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Petya109
Petya109
05.01.2021 07:59 •  Информатика

1. Дан массив целых чисел, состоящий из 15 элементов. Значение элементов массива задаются случайным образом в диапазоне от 10 до 80. Написать программу, которая считает количество элементов массива, значение которых больше 50.

2. Дан массив целых чисел, состоящий из 20 элементов. Значение элементов массива задаются случайным образом в диапазоне от 50 до 150. Написать программу, которая считает количество элементов массива, значение которых меньше 100.

На паскале. Сделайте так чтобы выполнялось

Ответ:
miccalinkanikon
miccalinkanikon
09.01.2021 12:03

Если не видно на скриншоте  (Я правильно понял,как нужно сделать?)

1)

Program v1;

var a:array[1..15]of integer;            

i,n,kol:integer;

begin          

randomize;

for i:=1 to 15 do a[i]:=random(70)+10;                            

write('Значение матрицы: ');                                      

for i:=1 to 15 do write(a[i]:5); writeln;  

kol:=0;

 for i:=1 to 15 do

   if a[i]>50 then kol:=kol+1;

 writeln(kol);

 end.

   2)

Program v1;

var a:array[1..20]of integer;            

i,n,kol:integer;

begin            

randomize;

for i:=1 to 20 do a[i]:=random(100)+50;                            

write('Значение матрицы: ');                                      

for i:=1 to 20 do write(a[i]:5); writeln;  

kol:=0;

 for i:=1 to 20 do

   if a[i]<100 then kol:=kol+1;

 writeln('Количество элементов массива, значение которых меньше 100: ',kol);

 end.

   

   


1. Дан массив целых чисел, состоящий из 15 элементов. Значение элементов массива задаются случайным
1. Дан массив целых чисел, состоящий из 15 элементов. Значение элементов массива задаются случайным
0,0(0 оценок)
Ответ:
meri62
meri62
09.01.2021 12:03

##

// #1

var a := ArrRandom(15, 10, 80);

a.Println.Count(t -> t > 50).Println;

// #2

var b := ArrRandom(20, 50, 150);

b.Println.Count(t -> t < 100).Println


1. Дан массив целых чисел, состоящий из 15 элементов. Значение элементов массива задаются случайным
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?