В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lianadoschik12
lianadoschik12
13.01.2023 09:59 •  Информатика

составить программу С++, используя оператор FOR. 1 У гусей и кроликов вместе 64 лапы. Сколько может быть кроликов и гусей (указать все сочетания и количество вариантов)?
2 Составить программу, используя оператор FOR.
Составить программу для определения N! – M!, где N!=1*2*3*…*. N . N и М задает пользователь

Ответ:
steshina27
steshina27
04.01.2021 17:28

1)

#include <iostream>

using namespace std;

int main()

{

int g, k, n=64;

for (g=0; g<=n; g++)

{

for (k=0; k<=n/2; k++)

{

if (2*g + 4*k == n)

{

printf ("Gycu - %d. \nKpoluk - %d.\n\n", g, k);

}

}

}

return 0;

}

2)#include <iostream>

using namespace std;

long double fact(int N)

{

if(N < 0)

return N;

if (N == 0)

return 1;

else

return N * fact(N - 1);

}

int main()

{

int N, M;

setlocale(0,"");

cout << "N=";

cin >> N;

cout<<"M=";

cin>>M;

cout<<"N!-M!=" << fact(N)-fact(M) << endl << endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?