В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vikakivi1206
vikakivi1206
29.07.2022 15:47 •  Информатика

Составить программу записывающее четырехзначное число наоборот

Ответ:

var a,x,b,y,z,c,r,m:integer;

begin

write ('a=');

readln (a);

r:=a div 1000;

m:=a mod 1000;

x:=m div 100;

b:= m mod 100;

y:=b div 10;

z:=b mod 10;

c:= z*1000+y*100+x*10+r;

writeln ('c=' , c);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?