В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
enc0r3
enc0r3
31.07.2020 01:10 •  Информатика

Написать программу на языке pascal решения квадратного уравнения. программа должна проверять правильность введенных пользователем данных и в случае, если коэффициент при второй степени неизвестного равен нулю, выводить соответствующее сообщение. нужно

Ответ:
денис1139
денис1139
12.06.2020 12:56

Program yravnenie;

Var
 a,b,c,D,x1,x2,p,q:Real;
Begin
 Repeat
  Write('a= ');
  Readln(a);
  if a=0 then writeln('Error: a=0. Enter another value');
 Until a<>0;
 Write('b= ');
 Readln(b);
 Write('c= ');
 Readln(c);
 p:=b/a;
 q:=c/a;
 D:=Sqr(p/2)-q;
 If D>0 then
  begin
   Writeln('x1 = ',-p/2-Sqrt(D):0:5);
   Writeln('x2 = ',-p/2+Sqrt(D):0:5);
  end
 else
 If D=0 then
  Writeln('x1 = x2 = ',-p/2:0:5)
 else
  begin
   Writeln('x1 = ',-p/2:0:5,'-i*',Sqrt(-D):0:5);
   Writeln('x2 = ',-p/2:0:5,'+i*',Sqrt(-D):0:5);
  end;
 Readln;
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?