В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
BitBul1
BitBul1
03.03.2020 13:17 •  Информатика

Напишите 2 простые программы на C++ 1. Задать одномерный массив целых чисел. И образовать из него два отсортированных по возрастанию массива, содержащих четные и нечетные числа.

2. Генератором случайных чисел задан одномерный массив из действительных чисел. Найдите максимальное и минимальное число этого массива.

Ответ:
сашулька00001
сашулька00001
18.12.2020 12:53

1.

#include <iostream>

#include <vector>

using namespace std;

int main(){

int a,b;

cin>>a;

vector<int> v1;

vector<int> v2;

for(int i=0; i<a; i++){

cin>>b;

if (b%2==0) v1.emplace_back(b);

else v2.emplace_back(b);

}

sort(v1.begin(), v1.end());

sort(v2.begin(), v2.end());

for(auto & i: v1) cout<<i<<" ";

}

2.

#include <iostream>

#include <vector>

using namespace std;

int main(){

vector<float> v;

//здесь нам задают массив

sort(v.begin(), v.end());

cout<<v[0]<<v.back();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?