В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
PEWALWIK
PEWALWIK
06.07.2020 10:55 •  Информатика

Написать программу, которая в массиве случйных чисел с[1..5,1..5] меняет местами значения элементов главной и диагонали

Ответ:
ressko123
ressko123
30.09.2020 20:54

uses crt;

var C:array[1..5,1..5] of integer;

i,j,temp:integer;

 

begin

   randomize();

   for i:=1 to 5 do

      for j:=1 to 5 do

         C[i,j]:=random(1000);

   for i:=1 to 5 do begin

      t:=C[i,i];

      C[i,i]:=C[i,6-i];

      C[i,6-i]:=t;

   end

end.

0,0(0 оценок)
Ответ:
fjfnk
fjfnk
30.09.2020 20:54

program pr;
uses crt;
Var i,j,b:integer;
C:array[1..5, 1..5] of integer;
Begin
for i:=1 to 5 do Begin
Writeln;
    for j:=1 to 5 do Begin C[i,j]:=random(100); Write(C[i,j],'|');  end;
     end;
for i:=1 to 5 do
     Begin
           b:=C[i,i];
           C[i,i]:=C[i,6-i];
           C[i,6-i]:=b;
      end;
Writeln;
      
for i:=1 to 5 do Begin
Writeln;
    for j:=1 to 5 do  Write(C[i,j],'|');
     end;
      

readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?